SparkLabs Forum.

Community Help.


OpenVPN not connecting on Mountain Lion

Hi,

I'm trying to connect to an OpenVPN connection and for some reason I can't get it to work on Mountain Lion. It works perfectly in windows 7.

Here is the log from the app.

Code: Select all

Aug 15 17:43:35: Viscosity Mac 1.4.5 (1148)
Aug 15 17:43:35: Viscosity OpenVPN Engine Started
Aug 15 17:43:35: Running on Mac OS X 10.8.4
Aug 15 17:43:35: ---------
Aug 15 17:43:35: Checking reachability status of connection...
Aug 15 17:43:35: Connection is reachable. Starting connection attempt.
Options error: Unrecognized option or missing parameter(s) in /Library/ViscosityHelperTools/ActiveConnections/tmpP6qxTE.conf:25: register-dns (2.3.2)

The OpenVPN subsystem could not be started. Please check the following:
- Check for any error messages above this notification.
- Make sure Viscosity is not running under a File Vault protected location (put Viscosity in the Applications folder).
- Make sure the configuration is valid. Check the connection settings for the connection using Viscosity and make sure all settings are correct.


I can't even get tunnelblick to work. I hope you can help me.
Hi scottsy,

The lines to look for in your log are:

Code: Select all

Options error: Unrecognized option or missing parameter(s) in /Library/ViscosityHelperTools/ActiveConnections/tmpP6qxTE.conf:25: register-dns (2.3.2)


These indicate that your configuration has the "register-dns" command listed, which is a Windows only command. To remove it, edit your connection in Viscosity, click on the Advanced tab, and remove the line it is on from the advanced commands area. Click Save, and try connecting again.

Cheers,
James
Absolutely fantastic sir.

This has fixed my problem. Thanks.

Now that I know viscosity works, I will purchase the full version. Thanks again.
3 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy