Route All problem

Got a problem with Viscosity or need help? Ask here!

sirrus

Posts: 1
Joined: Sun Oct 13, 2019 4:32 am

Post by sirrus » Sun Oct 13, 2019 4:49 am
I've got some trouble witht the route-all settings. Even when I set "All Traffic" to "Automatic (Set by server)" there will be a default route over vpn...

This is not the intended behaviour. My VPN servers do not set this route!

And there is no way to disable it - the other options are fixed VPN route all, or only ipv4 or ipv6 over vpn only.

Diabling pull is not an option - otherwise I'll need to set all routes and settings manually.

I don't have this issue when I use the OpenVPN community client.

Regards,
Andreas

Eric

User avatar
Posts: 906
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Mon Oct 14, 2019 12:05 pm
Hi Andreas,

Viscosity adds the 0/0 route you are most likely seeing as Windows requires a gateway for Network Location Awareness to work correctly. Please rest assure though that this 0/0 route is disabled and is not being used. You can confirm this by running a couple of trace routes to see where traffic is going.

Open a Command Prompt, then run the following, replacing www.vpn.com to a destination that should be routed over your VPN:
Code: Select all
tracert www.vpn.com
You should see the first hop matches your VPN server. You can press Control+C to cancel the tracert after the first hop is resolved.

Next, run the command again with a location that should not be over your VPN, you should see your ISP as the first hop.

Let us know if you see anything to the contrary.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
2 posts Page 1 of 1