Monterrey: Local network connection lost upon disconnect

Got a problem with Viscosity or need help? Ask here!

marku

Posts: 2
Joined: Tue Dec 07, 2021 11:26 am

Post by marku » Tue Dec 07, 2021 11:31 am
Experiencing an issue with Viscosity on Monterrey. The VPN will connect fine, but when I disconnect, I lose all network connectivity. I don't mean just the connection to the internet; even LAN connection is lost as both Ethernet and WiFi interfaces will report they are not connected to anything. The only way to recover even local networking is to reboot the Mac. I've tried uninstalling Viscosity, including the helper tool, and reinstalling, but the problem persists. Any idea what is going on here?

James

User avatar
Posts: 2143
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Wed Dec 08, 2021 12:03 am
Hi marku,

Please make sure the "Reset network interfaces on disconnect" option isn't enabled (under the Advanced tab in Viscosity's Preferences window) if it isn't required.

If it's already not enabled, try running through the steps at:
https://www.sparklabs.com/support/kb/ar ... connected/

Finally, please make sure your connection does not have any scripts set that could be disabling the network. Some users may use "kill script" scripts that are intentionally designed to disable the local network if the VPN connection is disconnected.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

marku

Posts: 2
Joined: Tue Dec 07, 2021 11:26 am

Post by marku » Wed Dec 08, 2021 2:27 pm
Hello James -- Thanks for your reply. The "reset network interfaces" preference appears to have been the problem. Wasn't aware that was there, nor how it got set. Appreciate the pointer!
3 posts Page 1 of 1