OpenVPN subsystem could not be started

Got a problem with Viscosity or need help? Ask here!

jmdemoor

Posts: 1
Joined: Tue Jul 08, 2014 1:31 am

Post by jmdemoor » Tue Jul 08, 2014 1:53 am
Last week Viscosity, which had been working fine on multiple Macs for quite some time, stopped connecting. It would just infinitely hang on connect for both Macs. (We have 2 separate licenses.) So I regenerated, downloaded and installed the VPN client. However, when attempting to connect, I now see the following dialog:

Connection Failed

The OpenVPN subsystem could not be started. Please see the log section (the third icon) in the Details window for more information.

Here is what the log shows, including version details.

Jul 03 22:46:55: Viscosity Mac 1.4.10 (1175)
Jul 03 22:46:55: Viscosity OpenVPN Engine Started
Jul 03 22:46:55: Running on Mac OS X 10.9.3
Jul 03 22:46:55: ---------
Jul 03 22:46:55: Checking reachability status of connection...
Jul 03 22:46:55: Connection is reachable. Starting connection attempt.
Options error: Unrecognized option or missing parameter(s) in /Library/ViscosityHelperTools/ActiveConnections/tmpLwQcNn.conf:17: 4qKf5rKibNd9v6DGuUPqWb+0AXVAqH8Dnme1cxo9alQ4XZrABAizAgEC (2.3.4)

The OpenVPN subsystem could not be started. Please check the following:
- Check for any error messages above this notification.
- Make sure Viscosity is not running under a File Vault protected location (put Viscosity in the Applications folder).
- Make sure the configuration is valid. Check the connection settings for the connection using Viscosity and make sure all settings are correct.

***

Please help. Mahalo.

Best,
Joe De Moor

James

User avatar
Posts: 2108
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Tue Jul 08, 2014 6:32 am
Hi Joe,

OpenVPN is indicating that there is a "4qKf5rKibNd9v6DGuUPqWb+0AXVAqH8Dnme1cxo9alQ4XZrABAizAgEC" command listed in the configuration file, which isn't a valid command. It's most likely a comment or inline certificate that wasn't structured correctly in the imported configuration file. You should be able to edit your connection in Viscosity, click on the Advanced tab, and remove the "4qKf5rKibNd9v6DGuUPqWb+0AXVAqH8Dnme1cxo9alQ4XZrABAizAgEC" line.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

tboto

Posts: 4
Joined: Sat Jul 26, 2014 1:40 pm

Post by tboto » Sat Jul 26, 2014 1:45 pm
Hi James,
Same problem here and the recommended fix does not work.
I'm running OS X 10.10 on 2013 MacBook Air.

Jul 26 13:33:16: Viscosity Mac 1.4.11 (1186)
Jul 26 13:33:16: Viscosity OpenVPN Engine Started
Jul 26 13:33:16: Running on Mac OS X 10.10
Jul 26 13:33:16: ---------
Jul 26 13:33:16: Checking reachability status of connection...
Jul 26 13:33:16: Connection is reachable. Starting connection attempt.
Options error: Unrecognized option or missing parameter(s) in /Library/ViscosityHelperTools/ActiveConnections/tmpaWlF82.conf:30: scramble (2.3.4)

The OpenVPN subsystem could not be started. Please check the following:
- Check for any error messages above this notification.
- Make sure Viscosity is not running under a File Vault protected location (put Viscosity in the Applications folder).
- Make sure the configuration is valid. Check the connection settings for the connection using Viscosity and make sure all settings are correct.

Jul 26 13:35:17: Viscosity Mac 1.4.11 (1186)
Jul 26 13:35:17: Viscosity OpenVPN Engine Started
Jul 26 13:35:17: Running on Mac OS X 10.10
Jul 26 13:35:17: ---------
Jul 26 13:35:17: Checking reachability status of connection...
Jul 26 13:35:17: Connection is reachable. Starting connection attempt.
Options error: Unrecognized option or missing parameter(s) in /Library/ViscosityHelperTools/ActiveConnections/tmpmqIpXU.conf:30: scramble (2.3.4)

The OpenVPN subsystem could not be started. Please check the following:
- Check for any error messages above this notification.
- Make sure Viscosity is not running under a File Vault protected location (put Viscosity in the Applications folder).
- Make sure the configuration is valid. Check the connection settings for the connection using Viscosity and make sure all settings are correct.


How do I fix this?

Cheers

tboto

James

User avatar
Posts: 2108
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Mon Jul 28, 2014 4:34 am
Hi tboto,

OpenVPN is indicating that there is a "scramble" command in your configuration file, which is not a valid OpenVPN command:
Options error: Unrecognized option or missing parameter(s) in /Library/ViscosityHelperTools/ActiveConnections/tmpaWlF82.conf:30: scramble (2.3.4)
Editing your connection in Viscosity, clicking on the Advanced tab, and removing the command from the commands area should allow the connection to proceed.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

tboto

Posts: 4
Joined: Sat Jul 26, 2014 1:40 pm

Post by tboto » Mon Jul 28, 2014 9:25 am
Hi James,
thanks for your reply.
... which command do I remove? I couldn’t see the error in the command line to edit it but maybe I was not looking in the right place as the log clearly says there is an error.
For the laymen (me) would you be able to post a picture or step by step instructions on how to resolve this issue?
Viscosity novice :)

Cheers

James

User avatar
Posts: 2108
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Mon Jul 28, 2014 10:11 am
Hi tboto,

1. From Viscosity's menu select the Preferences item
2. Select your connection in the connections list and click the "Edit" button
3. Click on the Advanced tab
4. You should see a box with a list of any advanced commands set for your connection.
5. Delete the whole line "scramble" is on from the box.
6. Click Save.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

tboto

Posts: 4
Joined: Sat Jul 26, 2014 1:40 pm

Post by tboto » Mon Jul 28, 2014 8:10 pm
Hi James,
I tired the above and no luck.
I deleted this command line: scramble obfuscate i8votvt8vvo88np9

This is the log now:
Jul 28 19:49:57: Viscosity Mac 1.4.11 (1204)
Jul 28 19:49:57: Viscosity OpenVPN Engine Started
Jul 28 19:49:57: Running on Mac OS X 10.10
Jul 28 19:49:57: ---------
Jul 28 19:49:57: Checking reachability status of connection...
Jul 28 19:49:57: Connection is reachable. Starting connection attempt.
Jul 28 19:49:59: OpenVPN 2.3.4 x86_64-apple-darwin [SSL (OpenSSL)] [LZO] [PKCS11] [MH] [IPv6] built on Jul 2 2014
Jul 28 19:50:23: WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
Jul 28 19:50:23: UDPv4 link local: [undef]
Jul 28 19:50:23: UDPv4 link remote: [AF_INET]80.82.65.187:443
Jul 28 19:51:23: TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Jul 28 19:51:23: TLS Error: TLS handshake failed
Jul 28 19:51:23: SIGUSR1[soft,tls-error] received, process restarting
Jul 28 19:51:34: WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
Jul 28 19:51:34: UDPv4 link local: [undef]
Jul 28 19:51:34: UDPv4 link remote: [AF_INET]80.82.70.236:443

The strange thing is I installed an old version of Viscosity Mac 1 (version 1 !) and that works with OS X 10.10!
Jul 28 20:07:23 Viscosity Mac 1.0 (1219)
Jul 28 20:07:23 Viscosity OpenVPN Engine Started
Jul 28 20:07:23 Running on Mac OS X 10.10.0
Jul 28 20:07:23 ---------
Jul 28 20:07:23 State changed to Connecting
Jul 28 20:07:23 Checking reachability status of connection...
Jul 28 20:07:23 Connection is reachable. Starting connection attempt.
Jul 28 20:07:25 OpenVPN 2.3.4 i386-apple-darwin [SSL (OpenSSL)] [LZO] [PKCS11] [MH] [IPv6] built on Jun 6 2014
Jul 28 20:07:26 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
Jul 28 20:07:26 UDPv4 link local: [undef]
Jul 28 20:07:26 UDPv4 link remote: [AF_INET]184.75.210.42:53
Jul 28 20:08:26 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Jul 28 20:08:26 TLS Error: TLS handshake failed
Jul 28 20:08:26 SIGTERM[soft,tls-error] received, process exiting
Jul 28 20:08:26 State changed to Disconnected
Jul 28 20:08:27 Viscosity Mac 1.0 (1219)
Jul 28 20:08:27 Viscosity OpenVPN Engine Started
Jul 28 20:08:27 Running on Mac OS X 10.10.0
Jul 28 20:08:27 ---------
Jul 28 20:08:27 State changed to Connecting
Jul 28 20:08:27 Checking reachability status of connection...
Jul 28 20:08:27 Connection is reachable. Starting connection attempt.
Jul 28 20:08:29 OpenVPN 2.3.4 i386-apple-darwin [SSL (OpenSSL)] [LZO] [PKCS11] [MH] [IPv6] built on Jun 6 2014
Jul 28 20:08:31 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
Jul 28 20:08:31 UDPv4 link local: [undef]
Jul 28 20:08:31 UDPv4 link remote: [AF_INET]89.248.172.172:53
Jul 28 20:08:31 State changed to Authenticating
Jul 28 20:08:31 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Jul 28 20:08:36 [TG-OVPN-CA] Peer Connection Initiated with [AF_INET]89.248.172.172:53
Jul 28 20:08:39 TUN/TAP device /dev/tun0 opened
Jul 28 20:08:39 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
Jul 28 20:08:39 /sbin/ifconfig tun0 delete
Jul 28 20:08:39 NOTE: Tried to delete pre-existing tun/tap instance -- No Problem if failure
Jul 28 20:08:39 /sbin/ifconfig tun0 10.9.0.26 10.9.0.25 mtu 1500 netmask 255.255.255.255 up
Jul 28 20:08:44 Initialization Sequence Completed
Jul 28 20:08:44 DNS mode set to Full
Jul 28 20:08:44 State changed to Connected

I'm sure how stable this old version is....

James

User avatar
Posts: 2108
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Tue Jul 29, 2014 2:13 am
Hi tboto,

Please see:
http://www.sparklabs.com/support/error_ ... 0_seconds/

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

tboto

Posts: 4
Joined: Sat Jul 26, 2014 1:40 pm

Post by tboto » Fri Aug 01, 2014 1:22 pm
Hi James,
your solution worked.
my VPN provider settings weren't working.
any way Viscosity Mac 1.4.11 (1213) works on Mac OS X 10.10.

Cheers

super_kev

Posts: 18
Joined: Fri Nov 14, 2008 3:05 am

Post by super_kev » Tue Aug 05, 2014 6:54 am
I have the same problem, but on a fresh install of 10.9.4 - this is the log. And the Python package is present.
Code: Select all
Aug 04 13:48:02: Viscosity Mac 1.4.10 (1175)
Aug 04 13:48:02: Viscosity OpenVPN Engine Started
Aug 04 13:48:02: Running on Mac OS X 10.9.4
Aug 04 13:48:02: ---------
Aug 04 13:48:02: Checking reachability status of connection...
Aug 04 13:48:02: Connection is reachable. Starting connection attempt.
Traceback (most recent call last):
  File "ViscosityHelper.py", line 1103, in <module>
  File "ViscosityHelper.py", line 134, in startOpenVPN
  File "/System/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/subprocess.py", line 594, in __init__
    errread, errwrite)
  File "/System/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/subprocess.py", line 1097, in _execute_child
    raise child_exception
OSError: [Errno 8] Exec format error

The OpenVPN subsystem could not be started. Please check the following:
- Check for any error messages above this notification.
- Make sure Viscosity is not running under a File Vault protected location (put Viscosity in the Applications folder).
- Make sure the configuration is valid. Check the connection settings for the connection using Viscosity and make sure all settings are correct.
11 posts Page 1 of 2