OpenVPN Version per Configuration

Got a problem with Viscosity or need help? Ask here!

slakr007

Posts: 2
Joined: Wed Jul 25, 2018 4:02 am

Post by slakr007 » Wed Jul 25, 2018 10:27 am
Sorry if this has been asked. I didn't find anything specifically related, though.

Is there a way to set the OpenVPN version under Advanced PER configuration rather than globally? I have a work VPN that just does not seem to work unless this is set to 2.3. However, I have a home VPN running 2.4. My home VPN connection seems to work fine with the version set to 2.3, but the purist in me would rather each connection match the server.

James

User avatar
Posts: 1923
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Fri Jul 27, 2018 2:01 pm
Hi slakr007,

The version can be overridden on a connection-by-connection basis by using the “#viscosity protocol-version” advanced command, for example "#viscosity protocol-version 2.3”. For information on how to specify advanced commands please see:
https://www.sparklabs.com/support/kb/ar ... n-commands

However, OpenVPN 2.4 is fully backwards compatible with OpenVPN 2.3, so I do recommend getting your connection to work using version 2.4 instead. The most common problem to run into is compression setting differences, which the following article should help with:
https://www.sparklabs.com/support/kb/ar ... ader-byte/

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

slakr007

Posts: 2
Joined: Wed Jul 25, 2018 4:02 am

Post by slakr007 » Fri Jul 27, 2018 2:35 pm
I ran into that compression article before. Not sure what I did the first time around, but this time I started with a clean version of the client configuration from work and carefully changed one thing at a time. I think the client configuration was borked from the start since it specified `comp-lzo no` but deleting that and setting compression to LZO in the options works with the OpenVPN version set to Automatic.

So, seems like it's all good now! Thanks, James.
3 posts Page 1 of 1