Catalina beta support

Got a problem with Viscosity or need help? Ask here!

urzasnet

Posts: 4
Joined: Sun May 14, 2017 8:24 am

Post by urzasnet » Wed Jun 26, 2019 1:11 am
I'm currently running Viscosity 1.7.17b3 -- am considering trying out the macOS Catalina public beta. As I understand macOS 10.15 no longer supports kernel extensions, I'm guessing even the latest beta doesn't run under the new OS. Or does it? I found release notes for the most recent non-beta release of Viscosity but I can't seem to find release notes for the beta track.

Just curious. Thanks!

James

User avatar
Posts: 1908
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Thu Jun 27, 2019 12:10 pm
Hi urzasnet,

The current version of Viscosity should run without issue (ignoring any potential macOS beta bugs).

Standard tun/routed connections do not require the use of a kernel extension (Viscosity uses inbuilt support in macOS). While tap/bridged connections do, Catalina still allows for kernel extensions that are properly signed and notarised (which Viscosity's are).

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

urzasnet

Posts: 4
Joined: Sun May 14, 2017 8:24 am

Post by urzasnet » Tue Jul 02, 2019 4:15 am
I'm now running macOS 10.15 beta (19A487m) and Viscosity 1.7.16 appears to be working fine. In the past, I've usually always operated under the beta track but, under Catalina, if I opt-in for beta updates and then try to install the latest version (1.7.17b3), the installer fails with the message "Failed to change owner & group on Viscosity.app to match Viscosity.app with authorization." Screenshot attached.

I am logged in as a standard user and authenticate installations using a separate admin-level account. However, I tried switching over to that admin user and updating while logged in there -- got the same error.

Anyway, my Viscosity is working fine using the standard release... just an FYI that something will need to be fixed in the future. Thanks for making such a handy app!
Attachments
viscosity_error.png
viscosity_error.png (157.42 KiB) Viewed 1159 times

James

User avatar
Posts: 1908
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Tue Jul 02, 2019 4:46 pm
You can find some more information regarding this, as well as a workaround, at:
https://twitter.com/sparklabs/status/1145532205789093889

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

urzasnet

Posts: 4
Joined: Sun May 14, 2017 8:24 am

Post by urzasnet » Fri Jul 05, 2019 11:35 pm
I can confirm the Sparkle problem was fixed in the second public beta of Catalina (19A501i). I am now back on the beta track -- thank you!
5 posts Page 1 of 1