DNS is leaked

Got a problem with Viscosity or need help? Ask here!

James

User avatar
Posts: 2108
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Sun Sep 12, 2021 10:17 pm
The VPN network is 192.168.100.x so it shouldn't, clash with the usual 192.168.1.x networks, please correct me if I am wrong.
A clash can occur if the local network is using the same IP range as the remote network. If the network you're connecting from is 192.168.100.x, and the remote VPN network also uses 192.168.100.x, then you have a clash.

Make sure that when testing your VPN connection you're not connecting from the same networking you're VPNing into. For example, if this setup is to allow remote access to your home, don't attempt to test it by VPNing from your home network. Disconnect from your home network and use a different internet connection (for example, tethered to your phone).

I recommend connecting to the VPN connection and viewing the routing table, to see whether there are any other 192.168.100.x ranges being used locally.
https://www.sparklabs.com/support/kb/ar ... ng-problem
The configuration data is
That all looks fine.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

pexis

Posts: 7
Joined: Mon Sep 06, 2021 8:54 am

Post by pexis » Tue Sep 14, 2021 1:10 am
Hi James,

so I went back to my home after being in Spain, using my cellphone as a hotspot I didn't have any kind of problems, I would reduce this to a clash of the IP address. The hotel was using 192.168.1.X and the VPN networks uses 192.168.100.X, what would be a recommended IP for the VPN network (at home)?

Cheers and thanks for the great support!
J

James

User avatar
Posts: 2108
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Tue Sep 14, 2021 6:32 pm
Hi pexis,

It sounds likely that while you were being assigned a 192.168.100.x IP address at the hotel, it was probably using the 192.168.1.x range as well (and pushing this out via the DHCP server). This is pretty common for large hotels (where they assign a different /24 or /16 range to each floor for example).

You have a couple of options:

1. You can change your home network to use a less common private range. You can see a list of available ranges at the link below. Typically picking something in the 10.x.x.x range has a greater chance of avoiding clashes (as it's a much larger available range). For example, you could use 10.123.45.x for your VPN network. By default OpenVPN uses 10.8.0.x addresses for the VPN network.
https://en.wikipedia.org/wiki/Private_n ... _addresses

2. You can leave your home network IP range as it is, and use a different IP range on the OpenVPN server and use NAT to remap the IP addresses. This is something you would need to consult your server documentation for, or find a guide.

OpenVPN also has a "client-nat" option, which allows you to remap IP addresses client side. For example, you could remap the 192.168.1.x to something like 10.1.2.x, and access things by the 10.1.2.x address instead. However it's complex to set up, and can result in problems when the server/device you're accessing isn't aware it's being accessed via a different IP address, so we don't recommend its use unless you have a strong computer networking background.
https://www.sparklabs.com/support/kb/ar ... client-nat

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
13 posts Page 2 of 2