OpenVPN 3 support

Suggestions/comments/criticisms are welcome here

vinca

Posts: 2
Joined: Tue Dec 08, 2020 8:10 pm

Post by vinca » Tue Dec 08, 2020 8:20 pm
Hello guys,

are there any plans to support the OpenVPN 3 core?

My story: My employer just migrated to the cloud version of OpenVPN. I can't connect to that VPN using Viscosity anymore, I believe it's due to the version of core lib used.

James

User avatar
Posts: 2109
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Thu Dec 17, 2020 4:01 pm
Hi vinca,

I'm afraid we have no plans to adopt the OpenVPN 3 project. OpenVPN 2.4, which is included with Viscosity, is capable of connecting to all OpenVPN servers, including the commercial OpenVPN-AS and OpenVPN Cloud servers.

In regards to OpenVPN Cloud specifically, Viscosity shouldn't have any problems connecting to it. I've just tested this today to make sure. However please note that if your company has SSO/SAML enabled for authentication, this is not currently supported by Viscosity. We'll be adding SSO/SAML support, along with OpenVPN 2.5 support, in a future update.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

vinca

Posts: 2
Joined: Tue Dec 08, 2020 8:10 pm

Post by vinca » Tue Jan 19, 2021 10:18 pm
Hi James,

thanks for your response. My company is using MS SSO to log in to cloud OVPN. That explains the issues.

Any idea when Viscosity will support SSO? Is there any roadmap customers can watch?

thank you and have a nice day,
Vinca
3 posts Page 1 of 1