Setting location from Public to Private

Got a problem with Viscosity or need help? Ask here!

msmfoster

Posts: 3
Joined: Mon Sep 15, 2014 4:41 am

Post by msmfoster » Mon Sep 22, 2014 5:41 am
Windows 8.1 has this option of setting a network as Public, Private or Home. Normally when a new wireless network is established, it will prompt the user to select a profile so we can establish trust in relations to network discovery or file and print sharing.

When I established a link with Viscocity or SecurePoint this was not asked. Now I have followed various tutorials and found this one to be the best one (so far): http://www.eightforums.com/tutorials/98 ... s-8-a.html Option 4 being the best one so far, however all it does it allow me to override Unidentified Networks to Private by default.

Is there a better way of getting this done? All of the other methods will not even show the VPN connection, even when I am currently active on it. It would admittedly be nice to be able to configure that capability instead of a blanket trust on all Unidentified Networks.

Eric

User avatar
Posts: 906
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Mon Sep 22, 2014 1:30 pm
Hi msmfoster,

For a Network to be considered as 'identified' by Windows, it must have a gateway address, something that is not necessary for the majority of VPN setups. You can however spoof one.

Edit your connection and go to the Networking tab. Add a new route with:

Destination: 0.0.0.0
Mask: 0.0.0.0
Gateway: VPN Gateway
Metric: 999

This will add a gateway automatically each time you connect. This will then set the VPN adapter to something Identified (Network 2 for example). However, while this would nomrally then prompt you to select a network type on Windows 7 and below, on Windows 8 it doesn't appear to be the case anymore, it is staying as public in our testing without an option to change. You may have better luck on your end.

Once this is done though, the network is identified, so you may be able to set it permanently to private using option 3 (the registry option) in the article that you linked. You will probably have to disconnect/reconnect for the network to change it's display after changing the registry entry for the profile.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
2 posts Page 1 of 1