scripting from within a service

Got a problem with Viscosity or need help? Ask here!


Posts: 1
Joined: Sat Sep 23, 2017 10:41 am

Post by rbucker » Sat Sep 23, 2017 10:45 am
I have a simple service application... running as SYSTEM. However when I try to run ViscosityCC.exe from within the service I get some sort of error message regardless of the command: STATUS, CONNECT, DISCONNECT.... in particular "Not Found".

I thought it might be permissions so I tried to change the perms so that everything was running as admin but nothing seeme to work. I tried accessing the configurations by number and that did not work either.


User avatar
Posts: 986
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Mon Sep 25, 2017 10:16 am
Hi rbucker,

Viscosity connections are stored by user. This means that the user that has the connections stored needs to be the one that runs ViscosityCC. You may also need Desktop Interaction permissions on the service to run Viscosity from a service.

Eric Thorpe
Viscosity Developer

2 posts Page 1 of 1