Can't connect to RDP after viscosity installation

Got a problem with Viscosity or need help? Ask here!

elweilando

Posts: 2
Joined: Fri Jan 05, 2018 3:34 am

Post by elweilando » Fri Jan 05, 2018 3:49 am
heyho!

I need to connect to an openVPN from an azure windows 2016 R2 virtual machine.
After the installation of viscosity v1.7 I can't connect anymore to the RDP and it seems that the vm has no network more.

knows anybody how I can fix this or what the reason for this issue is?

Eric

User avatar
Posts: 1116
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Fri Jan 05, 2018 12:27 pm
Hi elweilando,

Please start with the following to try and determine what is causing the issue - http://sparklabs.com/support/kb/article ... connection

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

elweilando

Posts: 2
Joined: Fri Jan 05, 2018 3:34 am

Post by elweilando » Wed Jan 10, 2018 1:02 am
ipconfig and routes are unchanged after installation. but if I restart the azure vm, I can't connect anymore to the azure vm.
I use now the openvpn-client (OpenVPN 2.4.4 -- released on 2017.09.26) and it works.

Eric

User avatar
Posts: 1116
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Wed Jan 10, 2018 11:54 am
Hi elweilando,

It sounds like you might have DNS misconfigured on your server, most likely Split DNS is forcing lookups across the VPN due to domains you are pushing, or your server does not know about your RDP DNS due to it being local and Viscosity is set to Full DNS. You can adjust your DNS on your server to correct this problem, or you can turn off this behaviour by setting the DNS Mode on the connection to Full DNS (Edit the connection and go to the Networking tab), and then going to Preferences -> Advanced and ticking "Use Windows DNS System for Full DNS".

http://sparklabs.com/support/kb/article ... #dns-modes

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

sullrich

Posts: 5
Joined: Wed Feb 17, 2021 2:37 am

Post by sullrich » Fri Aug 06, 2021 5:09 am
We just experienced this same issue. It does not appear to be DNS related.

Remote Desktop Service starts but once Viscsosity starts we no longer see port 3389 accepting inbound connections after rebooting.

Eric

User avatar
Posts: 1116
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Fri Aug 06, 2021 10:00 am
Hi sullrich,

We've seen reports on Azure VMs that DHCP fails after additional non-azure adapters are installed, for some reason Azures DHCP service cannot handle more than one adapter on a VM, you will need to contact Azure for support about this. To get around this, you will need to set a static IP address on your default ethernet adapter.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

sullrich

Posts: 5
Joined: Wed Feb 17, 2021 2:37 am

Post by sullrich » Tue Aug 17, 2021 7:07 am
That makes sense. Thanks for the info!
7 posts Page 1 of 1