SparkLabs Forum.

Community Help.


ERROR: You do not have access to the following "tls-crypt"..

Hello!

I have created a profile that works fine with my OpenVPN server. To make things more secure i chose to use tls-crypt.

So to give other people easy access i have exported the profile.
Then i tried to import it again to make sure it works, but it doesnt.

When i try to connect i get this error:
----------------------------
ERROR: You do not have access to the following "tls-crypt" key or certificate in order to use it for this connection:
C:\Users\me\AppData\Roaming\Viscosity\OpenVPN\1\tlscrypt.key
Please contact your Administrator for further assistance.
----------------------------

So, if i go to Settings and edit the connection under Authentication (remove and re-add the tlscrypt.key file from the exported profile), it works fine...

If i remove the exported profile it fails with the same message again.

How to resolve this?

wbr / Alex
I have now tried the profile on several (both English and Swedish) Windows computers, and all get the same error message.

The profile works fine for Mac though.
Hi Alex,

It looks like there was a bug in importing the tls-crypt file. We have corrected this and a fix is available in the next beta (1.7.7b7) which should be available soon. Please give it a try and let us know if the problem persists - http://sparklabs.com/support/kb/article ... -versions/

Regards,
Eric
@Erik Ah cool, thanks!

But do you mean 1.7.8b7? Because it seems that 1.7.7 is already out:)
Hi Alex,

Yes, 1.7.8b7, sorry for any confusion.

Regards,
Eric
5 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy