Split DNS issue

Got a problem with Viscosity or need help? Ask here!


Posts: 3
Joined: Tue Jun 26, 2018 11:45 am

Post by brianjlowry » Tue Jun 26, 2018 11:54 am

I haven't used my OpenVPN server in a bit as it's only for working remotely, but I recently replaced my mobo/processor for my desktop - which changed my IP (new MAC), and at the same time swapped out the laptop I was using to VPN in.

I've also updated pfSense to the latest version 2.4.3 and the same with Viscosity (non-beta).

I've followed tutorials and instructions and read through a million threads and haven't found a solution.

Basically, I am able to connect to the OpenVPN server, but the split DNS is not pulling back the "dns servers" (they aren't named). One is my LAN interface and the other is Google WiFi which the entire house feeds through to ensure that wireless can see wired. Something has changed, and I don't know what to do...

I can RDP to my desktop from the laptop on the same WiFi network, but not through an OpenVPN on an external network (mobile hotspot), and I get errors about Split DNS being used without any DNS domains being present. If I switch to full, it still doesn't work.

I'm at a loss and this is just a step above my pay grade. Any help would be greatly appreciated!


User avatar
Posts: 1091
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Tue Jun 26, 2018 1:18 pm
Hi Brian,

It sounds like you're seeing this in the log, hopefully this article will help - https://sparklabs.com/support/kb/articl ... e-present/

If DNS is not working with Full DNS however, it sounds like your DNS server on your VPN server may not be responding to requests, you could have a firewall issue blocking VPN traffic from reaching your local network, the following should help you diagnose the problem - https://sparklabs.com/support/kb/articl ... -problems/

Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs


Posts: 3
Joined: Tue Jun 26, 2018 11:45 am

Post by brianjlowry » Wed Jun 27, 2018 12:25 am
Thanks for the reply, Eric.

All of the steps worked fine for me, other than the actual connecting part. I can ping, I can ping google.com and the IP is resolved, and "route print" shows the correct IP range.

I'm not sure what else to do? This was all working fine before, and I didn't have many problems setting it up. Very strange...

*edit: the above steps worked regardless of whether or not I chose split/full.


Posts: 3
Joined: Tue Jun 26, 2018 11:45 am

Post by brianjlowry » Wed Jun 27, 2018 1:24 am
I figured it out. At some point in my upgrading, either I changed the OpenVPN_Server interface assignment (by accident) or it was re-assigned.
4 posts Page 1 of 1