Socks proxy returned bad reply

Got a problem with Viscosity or need help? Ask here!


Posts: 1
Joined: Mon Feb 25, 2019 9:53 pm

Post by Victoriasan » Mon Feb 25, 2019 10:13 pm
Hi, I followed the guide on setting the obfs4 on my windows and i configured the proxy server on my raspberry pi. My Pi runs the pivpn+obfs4. The status shows all running and enabled. But when i tried to connect to it, the client's log shows "socks proxy returned bad reply". It keeps connecting nonstop. But my TCP connection established and my server is reachable. I have tried connecting to my pi without the obfs4, it works. But with it, my client stuck in connecting state. Btw, the result also the same when im using Scramblesuit Server. Please help :cry:


User avatar
Posts: 1115
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Tue Feb 26, 2019 12:13 pm
Hi Victoriasan,

Please ensure you have changed the port in your configuration to match the port obfsproxy is listening on, this is the most common thing forgotten.

If you're on the right port, you can check obfsproxy server side logs, these should be in /var/log/syslog, if the connection is establishing, you should see something in the logs.

If not, also check there isn't a firewall on your Pi that is blocking the port that Obfsproxy is listening on.

Eric Thorpe
Viscosity Developer



Posts: 1
Joined: Thu Aug 08, 2019 3:16 am

Post by Milly » Thu Aug 08, 2019 3:18 am

I had the same issue. For the benefit of others, the issue for me was that I had not setup my router to forward traffic on port 12345 to the VPN server. The tutorial on setting up the VPN server specifically mentions doing this, but its not mentioned in the tutorial on setting up obsfucation, so easily forgotten!

3 posts Page 1 of 1