Viscosity 1.8 Beta DNS Problem

Got a problem with Viscosity or need help? Ask here!

SomeOneInEurope

Posts: 10
Joined: Tue Aug 11, 2015 5:03 pm

Post by SomeOneInEurope » Tue Aug 27, 2019 3:47 pm
I recently updated to Viscosity 1.8 (1620) Beta2.

While everthing works as expected (before and) when i am using the vpn connection, the DNS seems to fail after i quit the vpn connection. After canceling the VPN connnection i have no access to any website.

(Does not happen with Viscosity 1.7 or earlier)

(Windows 10 - Version 1903, Build 18362.295)

Eric

User avatar
Posts: 906
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Tue Aug 27, 2019 3:52 pm
Hi SomeOneInEurope,

Thanks for the report. Could you please post a copy of your routing table and ipconfig after disconnecting? To get these, open a Command Prompt and type in the following each followed by Enter:

route print
ipconfig -all

You may with to email these to us instead as this is a public forum:
https://www.sparklabs.com/support/#contact

A copy of your configuration file would also be appreciated, you can get this by holding Shift and right clicking the Connection in Preferences then selecting View Configuration Data.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

SomeOneInEurope

Posts: 10
Joined: Tue Aug 11, 2015 5:03 pm

Post by SomeOneInEurope » Tue Aug 27, 2019 5:29 pm
ok, i've sent the data to your support address

Eric

User avatar
Posts: 906
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Tue Aug 27, 2019 5:47 pm
Hi SomeOneInEurope,

It looks like DNS has become stuck somehow. Could you please do the following:

Open Task Manager and go to the Services Tab. Locate ViscosityService in the list, right click it and select Stop, then right click it again and select Start. This should restore DNS to how it was before the connection.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

SomeOneInEurope

Posts: 10
Joined: Tue Aug 11, 2015 5:03 pm

Post by SomeOneInEurope » Tue Aug 27, 2019 6:00 pm
i stopped and restarted the ViscosityService and the DNS works again :)

Eric

User avatar
Posts: 906
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Tue Aug 27, 2019 6:01 pm
Thanks for letting us know! We'll continue to investigate the problem in the mean time.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
6 posts Page 1 of 1