Office offline after VPN connection

Got a problem with Viscosity or need help? Ask here!

Eric

User avatar
Posts: 1090
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Mon Sep 21, 2020 10:08 am
Hi Pat,

I'm afraid we're seeing this both ways at the moment. We're seeing users who have problems with Viscosity and not OpenVPN GUI, and we are seeing users who have issues with OpenVPN GUI and not Viscosity. It does seem to be random and down to when NCSI does it's check in relation to when the VPN tunnel routing kicks in.

We are still actively investigating this though and any extra data would be helpful. If you could please post (or email us) a copy of your configuration (Hold shift, right click the connection and click View Configuration data) and a copy of your log once connected, this would help a great deal.

As previously mentioned, we have reported this to Microsoft and there appears to be a fix in Windows 20H2 in the insider builds, we're not sure why this hasn't been included in any Windows 2004 rollups though.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

Eric

User avatar
Posts: 1090
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Tue Sep 29, 2020 7:27 pm
Hi All,

We've made some changes in Viscosity 1.9 Beta2 that will allow NSCI and NLA to function on Windows 10 2004+, meaning applications like Office should detect they have an Internet Connection when using Viscosity. In most cases this detection happens instantly, but due to factors we can't control in Windows location awareness, occasionally it could take a minute or two. Office won't automatically detect it has internet in this case, you will need to close the application and reopen it if there is some delay, or as others have said, have Office open before connecting.

Please give this latest beta a go and let us know if you have any feedback - https://sparklabs.com/support/kb/articl ... -versions/

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

Philz

Posts: 2
Joined: Tue Nov 10, 2020 1:09 am

Post by Philz » Tue Nov 10, 2020 1:18 am
Hi Eric,

Viscosity Beta 1.9 (Beta 6 currently) fixes this issue for me. Can you tell when 1.9 is going to be the stable release? I don't want to roll out Beta to more than 100 Clients

Best regards
Phil

Eric

User avatar
Posts: 1090
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Tue Nov 10, 2020 8:01 am
Hi Phil,

Thanks for the feedback, it's highly appreciated. We're expecting 1.9 to be released this week.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

Philz

Posts: 2
Joined: Tue Nov 10, 2020 1:09 am

Post by Philz » Thu Nov 19, 2020 7:44 pm
Hi Eric,

unfortunately after installing Stable we are back with the globe symbol in tray and Office applications thinking they are offline. It is not all the time but especially when coming back from Energy Saving Mode in Windows. I currently tested with Windows 10 2009 (20H2).
"Sometimes" when I disconnect and start the VPN connection again, everything seems fine for some time. Is there any more Ideas on this?

Best regards
Phil

Eric

User avatar
Posts: 1090
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Fri Nov 20, 2020 10:18 am
Hi Phil,

There is no way we can force it to do an NCSI check unless a network change happens. As you have noted, disconnecting and reconnecting will do this for example. I'm afraid we see this from time to time on WiFi as well with no VPN connected. Modern Standby could be causing issues here, could you please try hibernating your laptop instead of sleeping it to see if this helps.

If you do wait a few minutes after waking from sleep, Windows will do a check eventually, however it's on a timer which is why you've noticed this only happens sometimes.

Please also ensure you haven't disabled IPv6 as Windows relies on this more heavily now.

Playing with some settings in Windows may also help this case. Go to gpedit.msc, Administrative Templates -> Network -> Network Connectivity Status Indicator and try enabling Specify Global DNS, this can make Windows much less strict with its Internet checks.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
16 posts Page 2 of 2