DNS problem.

Got a problem with Viscosity or need help? Ask here!

DennisT

Posts: 3
Joined: Tue Jul 14, 2020 8:30 am

Post by DennisT » Thu Nov 19, 2020 9:53 am
Hi,
I'm running Win 10 2016 LTSB v1607 and Viscosity 1.9 (1695). The PC NIC is set up with a IPV4 static IP and IPV6 is disabled. Under TCP/IP settings I have Append these DNS suffixes (in order) checked and 3 domains defined. I also have Register this connection's addresses in DNS and Use this connection's DNS suffix in DNS registration checked.

I VPN to another site at domain2. Domain2 is added to the DNS suffix list at the top (first). However when I disconnect then close Viscosity the domain remains at the top of the list. This then screws up my logoff/login (roaming profiles) as the PC can't find the file server as it looks to domain2 which I'm not even connected to.

I've been manually removing the added domain each time I get out of the client but clearly something is wrong. I think Viscosity should remove the domain it added to the list. Is this a bug or do I have something set up that makes the PC not quite compatible with Viscosity?

Eric

User avatar
Posts: 1090
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Thu Nov 19, 2020 11:14 am
Hi Dennis,

This is a bug that can sometimes occur that is caused by older versions of Windows when adapter order is changed. We added further mitigations in 1.9 however I'm afraid we're having problems resolving this completely.

This is no longer an issue on Windows 10 1809 and higher as we can use adapter-specific lists of domains and no longer need to use the global suffix list.

We'll certainly investigate this when we can and see if there's anything further we can do for older versions of Windows in 1.9.1, please keep an eye out for the betas.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
2 posts Page 1 of 1