Connection Problems since last update

Got a problem with Viscosity or need help? Ask here!

gsnerf

Posts: 2
Joined: Wed Jul 13, 2011 6:35 pm

Post by gsnerf » Wed Jul 13, 2011 6:40 pm
Hi there,

as of Viscosity 1.3.0 (1050) I have trouble using my previously fine working vpn connection. First my current connection log:
Code: Select all
Jul 13 10:26:16: Viscosity 1.3.0 (1050)
Jul 13 10:26:16: Checking reachability status of connection...
Jul 13 10:26:17: Connection is reachable. Starting connection attempt.
Jul 13 10:26:17: OpenVPN 2.2.0 Win32-MSVC++ [SSL] [LZO2] [PKCS11] built on Jun 22 2011
Jul 13 10:26:20: NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Jul 13 10:26:20: Control Channel Authentication: using 'XXX' as a OpenVPN static key file
Jul 13 10:26:20: LZO compression initialized
Jul 13 10:26:20: UDPv4 link local: [undef]
Jul 13 10:26:20: UDPv4 link remote: XXX.XXX.XXX.XXX:XXXX
Jul 13 10:26:20: [XXX-vpn-server] Peer Connection Initiated with XXX.XXX.XXX.XXX:XXXX
So it seems the connecion is successfull at first but it immediately disconnects afterwards (also no more messages in the log).

What struck me is
Code: Select all
NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
. As I have user defined commands in the connection properties that would most propably be my problem. '--script-security 2' seems like a compiler parameter so I assume there is nothing on my end that I can do about that? Would be neat if this could be fixed, I really need that VPN connection for work :)

Eric

User avatar
Posts: 960
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Wed Jul 13, 2011 8:25 pm
Hi gsnerf,

Some computers appear to have had a problem updating their existing adapter drivers in the last update. If you edit your connection, go to the Advanced tab, and remove the line starting with 'dev-node', then save the connection and try to connect again, you shouldn't have any problems after this.

We are considering a number of options to prevent this happening again in future updates.
What struck me is
Code: Select all
NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
. As I have user defined commands in the connection properties that would most propably be my problem. '--script-security 2' seems like a compiler parameter so I assume there is nothing on my end that I can do about that? Would be neat if this could be fixed, I really need that VPN connection for work :)
This will show up each time you connect and is completely normal, it will not effect your connections.

Let us know how you go.

Cheers,

Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

gsnerf

Posts: 2
Joined: Wed Jul 13, 2011 6:35 pm

Post by gsnerf » Thu Jul 14, 2011 7:57 am
Worked like a charm, thank you very much :)
3 posts Page 1 of 1