Installation Issue (unable to find a version of the runtime)

Got a problem with Viscosity or need help? Ask here!

tasaif

Posts: 1
Joined: Thu Jan 05, 2012 5:48 am

Post by tasaif » Thu Jan 05, 2012 5:59 am
I was getting an error with a clean install of Windows XP Professional.
The host was updated through Windows Update up to Service Pack 3 with all of the other packages.

The error read "unable to find a version of the runtime to run this application" when trying to import a connection from a configuration file. The solution was to install .NET Framework 2.0

It's probably a good idea to document somewhere that the Windows client depends on .NET Framework 4.0 AND 2.0

James

User avatar
Posts: 1969
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Thu Jan 05, 2012 8:45 am
Hi tasaif,

We actually just fixed this up in the version released today (version 1.3.5). Your correct that Viscosity's driver management tool was linked to an older version of the .Net Framework, however this shouldn't have been the case, and was the unfortunate result of an bug introduced in a recent update. The 1.3.5 update correctly links it against version 4 of the .Net Framework again.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
2 posts Page 1 of 1