VPN Connects, but can't see LAN or browse internet

Got a problem with Viscosity or need help? Ask here!

super_kev

Posts: 18
Joined: Fri Nov 14, 2008 3:05 am

Post by super_kev » Tue Mar 29, 2011 1:45 am
Hello,
I setup a VPN to a DD-WRT router using Viscosity about 1-2 years ago and haven't had to use it for the past 8 months or so. When I last used it there were no problems with connecting or seeing computers (streaming iTunes, etc.) on the VPN's LAN. However, now, I can connect just fine, but can't see or ping any computers on the VPN or browse the internet. Here at my settings, and I have not changed them so I'm trying to figure out what is wrong. I've updated the the latest version of Viscosity.

Server (DD-WRT VPN build router):
Code: Select all
mode server 
push "redirect-gateway def1" 
push "dhcp-option DNS 10.15.20.1"
comp-lzo
client-to-client 
tls-server 
dev tap0 
proto udp 
server-bridge 10.15.20.1 255.255.255.0 10.15.20.160 10.15.20.169 
keepalive 10 120 
dh /tmp/openvpn/dh.pem 
ca /tmp/openvpn/ca.crt 
cert /tmp/openvpn/cert.pem 
key /tmp/openvpn/key.pem
Viscosity Client (config.conf file)
Code: Select all
#-- Config Auto Generated By Viscosity --#

#viscosity startonopen false
#viscosity dhcp true
#viscosity dnssupport true
#viscosity name Office
#viscosity ipv6 false
remote ************ 1194 udp
pull
tls-client
ns-cert-type server
persist-key
ca ca.crt
redirect-gateway def1
nobind
persist-tun
cert cert.crt
comp-lzo adaptive
dev tap
key key.key
resolv-retry infinite
Any ideas?

James

User avatar
Posts: 2124
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Tue Mar 29, 2011 5:07 pm
Hi super_kev,

I'd say the ethernet bridge between tap0 and your networking interface is no longer setup on your DD-WRT router. You'll need to set it up again.

Also, as you are using the "server-bridge" bridge command on the server's end, there is no need to have DHCP enabled on Viscosity's end.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
2 posts Page 1 of 1