Viscosity through SSH Routing Issue

Got a problem with Viscosity or need help? Ask here!


Posts: 1
Joined: Wed Sep 30, 2009 5:47 am

Post by Deviant0ne » Wed Sep 30, 2009 6:14 am
I currently have two OpenVPN servers behind the same IP address; one server is running a Bridged configuration the other is running a Routed configuration. Each configuration has two different sub-configurations: a regular connection and a connection through an SSH tunnel. Both of the Bridged configurations work perfectly, as does the Routed configuration that doesn't require an SSH tunnel to connect.

My problem is the Routed configuration through the tunnel. To pull up the tunnel originally, I pull up an SSH session in Terminal:
Code: Select all
ssh -L [email protected]

I have the port correctly mapped in my router, so I know that's not the issue. Here is my configuration file for that connection:
Code: Select all
#-- Config Auto Generated By Viscosity --#

#viscosity startonopen false
#viscosity dhcp true
#viscosity dnssupport true
#viscosity name TunnelSSH
remote localhost 1195
tls-auth ta.key 1
proto tcp-client
ca ca.crt
cert cert.crt
dev tun
key key.key
down ~/Desktop/OVPN/
cipher BF-CBC
--script-security 3 system
up ~/Desktop/OVPN/
resolv-retry infinite
And my server configuration file:
Code: Select all
mode server

port 1195
proto tcp-server

dev tun



ca ca.crt
cert server.crt
key server.key
dh dh1024.pem
tls-auth ta.key 0

cipher BF-CBC

ifconfig-pool-persist ipp.txt
push "redirect-gateway def1"
push "dhcp-option DNS"
push "dhcp-option DOMAIN XXXXshhhhXXXX"
push "route"
max-clients 10

keepalive 10 120
status openvpn-status.log
verb 3
The tunnel connects correctly, but upon connecting, my SSH tunnels collapse and I am not able to access any type of website. I also know that the server configuration file has to be correct, because when I connect to the same server NOT through SSH, the connection works perfectly. Here is the output from Viscosity:
Code: Select all
Tue Sep 29 14:00:40 2009: WARNING: No server certificate verification method has been enabled.  See for more info.
Tue Sep 29 14:00:40 2009: NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Tue Sep 29 14:00:40 2009: Control Channel Authentication: using 'ta.key' as a OpenVPN static key file
Tue Sep 29 14:00:40 2009: LZO compression initialized
Tue Sep 29 14:00:40 2009: Attempting to establish TCP connection with [nonblock]
Tue Sep 29 14:00:41 2009: TCP connection established with
Tue Sep 29 14:00:41 2009: TCPv4_CLIENT link local: [undef]
Tue Sep 29 14:00:41 2009: TCPv4_CLIENT link remote:
Tue Sep 29 14:00:42 2009: [server] Peer Connection Initiated with
Tue Sep 29 14:00:43 2009: TUN/TAP device /dev/tun0 opened
Tue Sep 29 14:00:43 2009: /sbin/ifconfig tun0 delete
Tue Sep 29 14:00:43 2009: NOTE: Tried to delete pre-existing tun/tap instance -- No Problem if failure
Tue Sep 29 14:00:43 2009: /sbin/ifconfig tun0 mtu 1500 netmask up
Tue Sep 29 14:00:43 2009: /Applications/ tun0 1500 1544 init
Tue Sep 29 14:00:43 2009: Initialization Sequence Completed
The ports are correct on both the client and server: 1195 (1194 is in use by my Bridged server). I've been working on this for about a week now; I've tried everything I can think of, not to mention anything I've been able to find online. Any help anyone can provide would be much appreciated.
1 post Page 1 of 1