Viscosity will not route to lan devices on a Tomato server

Got a problem with Viscosity or need help? Ask here!


Posts: 2
Joined: Tue Sep 25, 2018 6:39 pm

Post by zzz2580 » Tue Sep 25, 2018 6:56 pm
My Viscosity to version 1.7.11.
My Tomato Router Version is 1.28.
My home LAN is with the router at
OpenVPN subnet/netmask is and

I followed Sparklab's instructions about how to configure the Tomato's OpenVPN Server and a Viscosity Client: ... viscosity/

My OpenVPN clients are able to connect with Viscosity to my Tomato's OpenVPN Server. They get an IP number Tomato's -> VPN Tunneling -> OpenVPN Server -> Server 1 -> Status will register a client when connected. However, there is NO ROUTING across the OpenVPN connection!

At first, I focused on the Tomato Router as the problem. Unlike GLuDeRo's post here: ... ice.72806/
My clients cannot ping nor any other device on
When I connect a second client at, neither client can ping each other.

I tried configuring a Tomato -> Administration -> Scripts -> Firewall script like GLuDeRo suggested. It didn't make a difference for me:
iptables -t nat -I POSTROUTING -s -o br0 -j SNAT --to $(nvram get lan_ipaddr)

Based on someone else's post somewhere, I tried this firewall script without success:
iptables -I FORWARD -s -d -j DROP

Here is my Tomato Routing Table. Everything looks reasonable: ... sp=sharing

From Tomato's -> Tools -> Ping, I cannot ping a client like However, I can ping
From the client, I cannot Ping nor can it even ping itself,
Based on this one small but unreliable test, I tend to think the problem is with Viscosity.

The problem occurs whether Viscosity is running on a Mac or PC.
"Send all traffic over VPN connection" doesn't make a difference.
I have entered my Lan's Default Gateway in Viscosity without routing success.

Can someone make some suggestions for me as to a possible solution to this routing problem? Maybe I need to set a static route in Viscosity?

I'll be happy to provide more information if requested.



User avatar
Posts: 964
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Wed Sep 26, 2018 12:03 pm
Hi Rob,

Please start by checking the log in Viscosity. It sounds like you have an issue with mismatched compression, probably because the version of OpenVPN in Tomato is quite old, please disable compression on both client and server side. The following articles should help: ... envpn-log/ ... ader-byte/

Eric Thorpe
Viscosity Developer



Posts: 2
Joined: Tue Sep 25, 2018 6:39 pm

Post by zzz2580 » Thu Sep 27, 2018 10:37 am

The compression setting was the problem!

"Adaptive" on Tomato and "Automatic" on Viscosity are incompatible.

"Disabled" on Tomato and "Off" on Viscosity works great!

Thanks you!
3 posts Page 1 of 1