Cannot connect to VPN (1.7.11)

Got a problem with Viscosity or need help? Ask here!

Kamara

Posts: 4
Joined: Sat Sep 08, 2018 8:37 pm

Post by Kamara » Sat Sep 08, 2018 8:48 pm
Hi.

I can no longer connect to my VPN. This is the log:
Code: Select all
sep 08 12:40:28: State changed to Connecting
sep 08 12:40:28: Viscosity Windows 1.7.11 (1576)
sep 08 12:40:28: Running on Microsoft Windows 10 Home
sep 08 12:40:28: Running on .NET Framework Version 4.7.03056.461808
sep 08 12:40:28: Bringing up interface...
sep 08 12:40:28: WARNING: The block-outside-dns option has been ignored as it is not required under Viscosity's DNS management system. For more information please see the following article: https://www.sparklabs.com/support/kb/article/warning-the-block-outside-dns-option-has-been-ignored/
sep 08 12:40:28: OpenVPN 2.4.6 Windows-MSVC [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Jul 20 2018
sep 08 12:40:28: library versions: OpenSSL 1.0.2o  27 Mar 2018, LZO 2.09
sep 08 12:40:29: Checking remote host "X.com" is reachable...
sep 08 12:40:30: Checking remote host "X.com" is reachable...
sep 08 12:40:32: Checking remote host "X.com" is reachable...
sep 08 12:40:32: Checking remote host "X.com" is reachable...
sep 08 12:40:33: No usable connection profiles are present
sep 08 12:40:33: State changed to Disconnected
It might have happened after i installed OVPN.se client. However, it does not work if i uninstall it. I have also tried reinstalling Viscosity, downloading the configfiles from OVPN.se again, and have reset the Windows firewall.

Eric

User avatar
Posts: 907
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Mon Sep 10, 2018 2:32 pm
Hi Kamara,

One of two things is generally happening here.

1. X.com is not resolvable. Restart your PC, and then try again. If you still can't connect, try doing an nslookup on X.com. If this works, move to 2

2. Something is blocking Viscosity's DNS system. This could be a firewall, permissions or another application, but basically Viscosity is unable to use port 53. If this started happening after installing a certain application, look around in case a part of that application was not removed properly when you uninstalled it. There could be a process or service still running in the background that came with that application.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

Kamara

Posts: 4
Joined: Sat Sep 08, 2018 8:37 pm

Post by Kamara » Sat Sep 22, 2018 6:54 pm
Eric wrote:
Hi Kamara,

One of two things is generally happening here.

1. X.com is not resolvable. Restart your PC, and then try again. If you still can't connect, try doing an nslookup on X.com. If this works, move to 2

2. Something is blocking Viscosity's DNS system. This could be a firewall, permissions or another application, but basically Viscosity is unable to use port 53. If this started happening after installing a certain application, look around in case a part of that application was not removed properly when you uninstalled it. There could be a process or service still running in the background that came with that application.

Regards,
Eric
Hi.

How do i do a nslookup, and what am I supposed to see in CMD when I am doing it?

Eric

User avatar
Posts: 907
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Mon Sep 24, 2018 11:00 am
Hi Kamara,

Open a Command Prompt, then type in:

nslookup X.com

And press Enter. If there is an error you will see it clearly in the output.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

Kamara

Posts: 4
Joined: Sat Sep 08, 2018 8:37 pm

Post by Kamara » Sun Sep 30, 2018 7:50 pm
Eric wrote:
Hi Kamara,

Open a Command Prompt, then type in:

nslookup X.com

And press Enter. If there is an error you will see it clearly in the output.

Regards,
Eric
OK, thanks. I did the nslookup om the command prompt. This was the result:
Code: Select all
C:\Users\XX>nslookup pool.prd.se.sthlm.ovpn.com
Server:  UnKnown
Address:  192.168.0.1

Non-authoritative answer:
Name:    pool.prd.se.sthlm.ovpn.com
Addresses:  46.227.67.160
          46.227.67.157
          46.227.67.148
          46.227.67.143
          46.227.67.145
          46.227.67.154
          46.227.67.141
          46.227.67.153
          46.227.67.149
          46.227.67.140
          46.227.67.155
          46.227.67.152
          46.227.67.151
          46.227.67.147
          46.227.67.150
          46.227.67.146
          46.227.67.142
          46.227.67.175
          46.227.67.144
          46.227.67.156
How does it look?

Eric

User avatar
Posts: 907
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Tue Oct 02, 2018 10:42 am
Hi Kamara,

In that case, something is blocking ViscosityService from using port 53 on your PC. Please ensure any recently installed applications have been removed correctly that you noticed the problem occurring after you installed them, if you're unsure about uninstalling other software you will need to contact support for where that software came from.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

Kamara

Posts: 4
Joined: Sat Sep 08, 2018 8:37 pm

Post by Kamara » Sun Oct 07, 2018 6:28 am
So, I solved it.

What I did:

I uninstalled the client from OVPN.se. Still did not work.
Reset the firewall, still did not work.
Went to the control panel > network connections and removed all other connections other than my WiFi, that is, I removed for example tap v9 adapter and Viscosity Virtual Adapter V.

Then I reinstalled Viscosity again, and it worked.
7 posts Page 1 of 1