Connectivity Test Fails With IPv6

Got a problem with Viscosity or need help? Ask here!

juchong

Posts: 1
Joined: Sat Nov 05, 2022 11:42 am

Post by juchong » Sat Nov 05, 2022 11:48 am
Hi,

It looks like Viscocity does not understand how to handle IPv6-only communication.

I'm connected to a WiFi network that only provides an IPv6 DHCP address. It does not provide an IPv4 address, but instead allows Windows to assign a private address (169.254.xxx.xxx). This connection also only provides IPv6 DNS servers.

The server I'm trying to connect to is "up" and responding to pings. The connection also "fails" when the IP address of the server (IPv4) is entered instead of an address that requires DNS lookup.

Please help!

James

User avatar
Posts: 2203
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Mon Nov 07, 2022 8:55 pm
Hi juchong,

Viscosity fully supports IPv6. I recommend checking the following:

1. You can set which IP protocol version will be used when connecting via the Protocol menu in the connection editor. For example, to use UDP over IPv6 select "UDP v6", to use IPv4 select "UDP v4", and to leave it up to OpenVPN select just "UDP". The same applies for TCP.
https://www.sparklabs.com/support/kb/ar ... s/#general

2. To use IPv6 the address in the Remote Server Address field either needs to be a IPv6 address, or a domain name that resolves to an IPv6 address (i.e. have a AAAA record). If it is a domain name that only resolves to a IPv4 address then IPv6 cannot be used, and the connection attempt will fail. You can check the connection log to see whether it's failing to find a IPv6 address.
https://www.sparklabs.com/support/kb/ar ... envpn-log/

3. The OpenVPN server you're connecting to needs to be configured to listen on its IPv6 address. If it's only bound to the server's IPv4 address, then even if the server itself has an IPv6 address (and responding to pings) you will not be able to connect.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
2 posts Page 1 of 1