Automatic reconnect frequently doesn't work

Got a problem with Viscosity or need help? Ask here!

syzygy

Posts: 2
Joined: Fri Dec 02, 2022 6:48 am

Post by syzygy » Fri Dec 02, 2022 8:12 am
Maybe it is my server I'm connecting to, but several times per week something will stop working and after wondering what's going on for a minute I'll see that Viscosity is reconnecting. When this happens, it seems that Viscosity is never able to actually reconnect on its own, but if I manually disconnect and reconnect it reconnects instantly.

1. Why doesn't the automatic reconnect work but manually disconnecting+connecting does?

2. I wish there was a macOS notification for the connection lost / reconnecting state. Viscosity already supports notifications for states I don't need a notification fort: connect/disconnect that I initiated myself. But it would be very useful to be notified that the connection was lost in a case where I didn't take any action to that effect.

James

User avatar
Posts: 2219
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Fri Dec 02, 2022 11:25 am
Hi syzygy,

There are two methods at play when a VPN connection reconnects: OpenVPN's internal reconnection behaviour, and Viscosity's reconnection behaviour. For small dropouts OpenVPN will attempt to re-establish the connection itself while not fully bringing down the VPN connection. In most cases this is what you want, so the connection seamlessly reestablishes. For full VPN cycles, Viscosity handles the reconnect behaviour (and you'll also receive notifications for these).

The following forum post goes into more detail regarding the reconnection behaviour of both, and how to control most aspects of it using settings and advanced commands:
viewtopic.php?p=9811#p9811

In your case it sounds like OpenVPN is trying to re-establish the VPN connection itself but is unable to (and isn't dropping back to letting Viscosity perform a full-reconnect). More information about what exactly is going on will be in the connection log. However you may like to simply disable OpenVPN's reconnect behaviour and leave it to Viscosity (see point 3 in the forum post linked above for how to do this).
https://www.sparklabs.com/support/kb/ar ... envpn-log/

Cheers,
James
Web: https://www.sparklabs.com
Support: https://www.sparklabs.com/support
Twitter: https://twitter.com/sparklabs

syzygy

Posts: 2
Joined: Fri Dec 02, 2022 6:48 am

Post by syzygy » Sat Dec 03, 2022 12:32 am
Very helpful info about the OpenVPN reconnect vs. Viscosity reconnect. I will try forcing the Viscosity auto-reconnect via the advanced commands you referenced in your post. Thank you, James!
3 posts Page 1 of 1