10.9 address every time (except after first install)

Got a problem with Viscosity or need help? Ask here!


Posts: 1
Joined: Sat Feb 23, 2013 12:12 am

Post by jjcoolaus » Sat Feb 23, 2013 12:19 am

Everytime I connect using Viscosity, the server gives me back a 10.9 or 10.8 IP address, which is a local LAN address.

The first connection I made with viscosity worked a treat, giving me a proper IP address in another country, but ever since then, it's been handing out 10.x.x.x addresses. What could be causing this?

I've tried completely uninstalling, restarting the pc, and reinstalling viscosity, to no avail. :(

I've also unticked "create new vpn connection every time" and i've also tried editing the connection and changing the routing to send all data over the VPN - that first time this wasn't necessary.

I've used a dns leak test website and a IP address website to confirm that I'm getting my static IP from my ISP every time.

After that first connection I thought "what a brilliant product" but now i'm a bit frustrated and don't know how to fix it.



User avatar
Posts: 973
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Sat Feb 23, 2013 2:36 pm
Hi Jason,

10.x.x.x IP addresses you receive from your VPN Providers server is correct behaviour. This is an internal IP address that links your computer to their server, and then their server is linked to the internet.

First try rebooting your PC to make sure that your routing table has not become invalid, otherwise if you are still not having your traffic routed over the VPN connection, you may have a problem with your configuration file or your VPN Provider could be pushing our some contradicting settings.

We highly recommend you contact your VPN Provider in regards to both of the above . If you are unsure who this is, please see - http://sparklabs.com/support/how_do_i_f ... _my_vpn_p/
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
2 posts Page 1 of 1