TAP Extension blocked by VirtualBox

Got a problem with Viscosity or need help? Ask here!

paleck

Posts: 2
Joined: Tue Apr 17, 2018 2:22 am

Post by paleck » Tue Apr 17, 2018 2:33 am
2018-04-16 10:25:00: Running on macOS 10.13.4
2018-04-16 10:25:00: ---------
2018-04-16 10:25:00: State changed to Connecting
2018-04-16 10:25:00: Checking reachability status of connection...
2018-04-16 10:25:00: Connection is reachable. Starting connection attempt.
2018-04-16 10:25:01: Error: The TAP system extension could not be loaded.
2018-04-16 10:25:01: Could not start connection: Status failure.
The only way I've found to fix it is to unload the all of the VirtualBox extensions, but then VirtualBox is broken:
$ kextstat | grep -v com.apple
Index Refs Address Size Wired Name (Version) UUID <Linked Against>
182 3 0xffffff7f82335000 0x64000 0x64000 org.virtualbox.kext.VBoxDrv (5.2.8) E68480EC-6423-30BA-9728-D1B0B5D606FE <7 5 4 3 1>
183 0 0xffffff7f83274000 0x8000 0x8000 org.virtualbox.kext.VBoxUSB (5.2.8) 6D97A7F9-6650-3AF5-9477-144D758EB0F0 <182 173 51 7 5 4 3 1>
184 0 0xffffff7f8327c000 0x5000 0x5000 org.virtualbox.kext.VBoxNetFlt (5.2.8) 324CE487-51AE-38A0-AED2-8F8DED2CFD8F <182 7 5 4 3 1>
185 0 0xffffff7f83281000 0x6000 0x6000 org.virtualbox.kext.VBoxNetAdp (5.2.8) 85257673-062A-35FB-9221-8AB980E0CE5A <182 5 4 1>
MBP-RJIMENEZ:~ robert.jimenez$

James

User avatar
Posts: 1876
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Tue Apr 17, 2018 8:36 am
Hi paleck,

Please ensure that you're not using an older version of Viscosity. Recent versions of Viscosity do include some changes to reduce the likelihood of driver clashes.

If you're already using the latest version and still seeing the same issue I'm afraid there is nothing further we can do about it on Viscosity's end.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

paleck

Posts: 2
Joined: Tue Apr 17, 2018 2:22 am

Post by paleck » Tue Apr 17, 2018 11:30 pm
I'm on 1.7.8 (1443), I had been on a previous version (1.7.6 i think) up until a week ago when first noticed the issue. These two programs used to coexist without issues, unfortunately it's been a few months since I needed to connect to a VPN server that utilized tap instead of tun so I can't tell you exactly when it broke.
3 posts Page 1 of 1