SparkLabs Forum.

Community Help.

Facing DSN Resolution Issues


Today the DNS resolution when connected on a VPN with Viscosity is not working.
My Mac is resolving addresses using its default DNS servers for the current wired connection, so resolution for internal addresses is not working.

I also tried to set DNS settings with "full DNS" and nothing changed, and I finally tried to set "split DNS" specifying internal servers (,, and internal domains.

Nothing changed.

My /etc/resolv.conf remains with the default configuration:

Code: Select all

Code: Select all

[email protected]:~$ cat /etc/resolv.conf
# macOS Notice
# This file is not consulted for DNS hostname resolution, address
# resolution, or the DNS query routing mechanism used by most
# processes on this system.
# To view the DNS configuration used by this system, use:
#   scutil --dns
#   dns-sd(1), scutil(8)
# This file is automatically generated.

My Viscosity version is 1.7.11 (1463).

Could you help me please?
Hi rafaelsolano,

The resolv.conf file is not used on macOS. Please refer to the comments included in that file as well as the following link: ... unix-users

You can find instructions for seeing which DNS servers are active on your machine at: ... being-used

I also recommend updating to the latest version of Viscosity (1.7.14 at the time of writing).

Hi, I also tried using a routerlogin guide for my WiFi and it helped along with your links.

Thanks for sharing these. XoXo
3 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy