No internet connection after 1.9.4

Got a problem with Viscosity or need help? Ask here!

SparkLabRon

Posts: 1
Joined: Mon Aug 30, 2021 9:30 pm

Post by SparkLabRon » Mon Aug 30, 2021 9:36 pm
Hello,

I have a colleague that after upgrading the client he has no internet connection after connecting to VPN.

After some digging it became clear that the issue is his DNS settings. The DNS server changes and becomes 127.56.49.53. There is no way for the machine to connect out to the internet. DNS or IP.

As a fix I did this which I found on a thread -

"...On the client, edit the connection, go to Networking, and set the DNS Mode to Full DNS. Save the connection, go to Preferences -> Advanced, and tick Use Windows DNS System for Full DNS."

This fixed the issue however, is not ideal...

Eric

User avatar
Posts: 1127
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Tue Aug 31, 2021 10:48 am
Hi Ron,

Please take a look at the log, this will tell you have DNS is setup and if there are any issues - https://sparklabs.com/support/kb/articl ... envpn-log/

You're welcome to post a copy here if you're unsure how to interpret it and we can take a look.
After some digging it became clear that the issue is his DNS settings. The DNS server changes and becomes 127.56.49.53.
This is normal behaviour for Viscosity. DNS issues should not prevent you connecting directly to IPs however, so something else may be going on in addition to DNS issues. We have some troubleshooting advice here as well, it may help - https://sparklabs.com/support/kb/articl ... -problems/

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

rps

Posts: 11
Joined: Wed Mar 18, 2015 5:05 am

Post by rps » Wed Sep 01, 2021 3:00 am
I'm getting reports of the same issue after the upgrade to 1.9.4 with clients being broken when moving from one network to another.

Eric

User avatar
Posts: 1127
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Wed Sep 01, 2021 9:25 am
Hi rps,

Could you please post logs per above and we can take a look at what is going on.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

rps

Posts: 11
Joined: Wed Mar 18, 2015 5:05 am

Post by rps » Wed Sep 01, 2021 9:37 pm
Only third party reports so far. It might be related to DNS clean-up on connection timeout if DNS servers provided by LAN and VPN are identical leaving no DNS servers enabled but that's just speculation at this point.

I will try to get someone who can reproduce the issue.
5 posts Page 1 of 1