No connection / Background services not running / Uninstall not possible (0xc000007b)

Got a problem with Viscosity or need help? Ask here!


Posts: 2
Joined: Tue May 17, 2022 2:10 am

Post by PSZ » Tue May 17, 2022 2:56 am
Dear all,

I am running out of ideas on how to find the problem.

I have been using Viscosity since March 2020 on my Microsoft Surface Pro X (ARM) as x86 (meanwhile on Windows 11). One of the core reasons to get viscosity was that it was running on my SPX - other than Sophos which my office was generally using.

A few days ago I set up Office 365 on my SPX. I noticed by chance that Viscosity would not establish a connection (profile/certificate being unchanged). Today I had to access our server externally and the same issue appeared.

So I tried to uninstall and re-install Viscosity. However, after choosing whether or not to keep my settings (I have tried both options and that part works) I get a 0xc000007b error that repeats endlessly. I can only exit that part via the task manager. I am also unable to install Viscosity on top of the existing application.

After opening the app and re-importing my certificate/profile, I now got an error notification by Viscosity, saying that the background service was not running. The automatic repair function did not work. Viscosity's troubleshooting FAQ basically says to re-install the latest version of Viscosity and to make sure to set exceptions in any antivirus software. My SPX is not running any antivirus on top of the pre-installed Windows software and I am unable to de-install the software.

I then tried to manually delete all program files in the x86 - Viscosity folder. I was initially unable to delete all data, but finally managed to do so, after manually stopping the ViscosityService via the task manager.

I then tried to re-install Viscosity only to find the exact same 0xc000007b error notification at the end of the installation process. Again, I can only exit these repeating notifications by shutting down the installer via the task manager.

Surprisingly, even though the installation process did not finish properly, Viscosity is now again installed and operable - but still unable to build up the connection I need.

I'd be grateful for all advice, as I am currently unable to work from home.

Thank you!


User avatar
Posts: 2182
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Tue May 17, 2022 5:51 am

This typically indicates there is a problem with the Visual C++ Redistributable on the machine. You should be able to resolve this by installing the latest Visual C++ Redistributable manually, and then run the Viscosity installer again.

You can download the latest Visual C++ Redistributable from: ... w=msvc-170

If you’re still stuck please let us know.

James Bekkema
Viscosity Developer



Posts: 2
Joined: Tue May 17, 2022 2:10 am

Post by PSZ » Tue May 17, 2022 4:25 pm
Hi James,

Thank you very much! This solved my issue immediately (and is indeed beyond my personal understanding of IT).

Have a great week!

3 posts Page 1 of 1