Viscosity stopped running on Windows 11 arm64

Got a problem with Viscosity or need help? Ask here!


Posts: 1
Joined: Fri Mar 17, 2023 12:10 pm

Post by untamedmind » Fri Mar 17, 2023 12:20 pm
Hopefully someone can help me out here.

I've got a Lenovo X13s running Windows 11 on ARM.

Viscosity has worked perfectly fine for me the past few months. Sent the machine in for a warranty repair and they wiped it. Fun, I had to reinstall everything.

Anyway to the point, when I reinstalled viscosity it worked fine until windows updates ran. Now it will not start at all. I tried uninstalling and reinstalling, and it keeps giving me errors during both uninstall and install.

So I thought back and remembered a similar thing happened previously and I had to remedy it by manually downloading Visual C++ for arm64.

I checked and sure enough the x64 version was installed, but not arm64.

I uninstalled the x64 version, installed the arm64 version, and restarted the machine. But now it's still doing the exact same thing.

Unintalled and reinstalled again, no change. I'm about to rip my hair out.

Any ideas?


Posts: 12
Joined: Wed Nov 30, 2022 2:53 pm

Post by Aaron » Sat Mar 18, 2023 4:07 am
Hi untamedmind,

Please follow the steps listed in the link below. In particular, both the uninstall and repair steps for the Visual C++ Redistributable are necessary to fix a broken runtime install on ARM64 machines. ... 0xc000007b

If Viscosity still isn't starting, also try performing a .NET repair. You can find the .NET Repair Tool linked at: ... fast-error

If you're still stuck, please let us know what errors or other messages you're seeing when attempting to run Viscosity or connect a VPN connection.

2 posts Page 1 of 1