Install of 1.10.6 always asks for .net 4.8.1

Got a problem with Viscosity or need help? Ask here!


Posts: 2
Joined: Fri Nov 17, 2023 2:05 am

Post by SamSmith123 » Fri Nov 17, 2023 7:50 am

I am having a problem installed the 1.10.6 version. We had 1.10.3 and when we tried to upgrade to 1.10.6 it always asked to update .Net 4.8.1. Tried to remove 1.10.3 and do a clean install of 1.10.6 same. Uninstall, installed .Net 4.8.1 then installed 1.10.6 and still asking for the installation of .Net.

Surface Pro X
Windows 10



Posts: 26
Joined: Wed Nov 30, 2022 2:53 pm

Post by Aaron » Wed Nov 22, 2023 12:20 pm
Hi Alan,

It sounds like you're using Windows 10 on an ARM device. This is a known issue: .NET is not installing correctly on certain Windows 10 on ARM setups. It’s likely related to Windows 10’s preferred x86 emulation.

It does not affect Windows 11, and so the best course of action is to update to Windows 11. This also has the added advantage of significantly improved performance, as it allows Viscosity to run fully natively.

However, we understand that there are still quite a few older Windows on ARM devices that don’t support Windows 11. So we’ve added a number of workarounds to the installer in the latest beta version that should resolve the issue. If you get a chance, please give it a try and let us know if you still encounter any problems. ... -versions/

I’ve also included the direct link to the current beta version (at the time of writing). We release updated betas regularly though, so for anyone coming across this post at a later date you'll probably want to use the automatic updater.



Posts: 2
Joined: Fri Nov 17, 2023 2:05 am

Post by SamSmith123 » Wed Dec 06, 2023 5:04 am
Hi Aaron,

I was able to upgrade that laptop to Windows 11 and install it and everything is working.

Thanks for your help

3 posts Page 1 of 1