Beta: Latest Build of Viscosity for Mac

Viscosity Menu Icon Packs, Two-Factor Scripts, & OpenVPN Config Tool

DJay

Posts: 12
Joined: Tue Jul 16, 2013 6:32 am

Post by DJay » Tue Aug 05, 2014 12:07 am
Thanks a lot James.. Viscosity 1.4.11b18 fixed my problems. :)
iMac 21.5 (Late 2012) | 3,1 GHz i7 | 16 GB RAM | OS X 10.10 | Safari 8.0

cwningen

Posts: 4
Joined: Sun Aug 03, 2014 6:36 am

Post by cwningen » Tue Aug 05, 2014 12:44 am
HMAC problem is fixed! IPv6 still fails though; is there anything I can provide to help? It does work manually but otherwise it fails on two different Yosemite DP4 installs.

RexZ

Posts: 2
Joined: Sat Aug 02, 2014 12:53 am

Post by RexZ » Tue Aug 05, 2014 12:51 am
The latest build/release worked for me! You're awesome James.

DJay

Posts: 12
Joined: Tue Jul 16, 2013 6:32 am

Post by DJay » Tue Aug 05, 2014 2:00 am
Oh.. I overlooked this.. without changing anything at the VPN Settings to my company, Viscosity is not connecting anymore. :?:
Code: Select all
Aug 04 17:49:09: Viscosity Mac 1.4.11 (1217)
Aug 04 17:49:09: Viscosity OpenVPN Engine Started
Aug 04 17:49:09: Running on Mac OS X 10.10
Aug 04 17:49:09: ---------
Aug 04 17:49:09: Checking reachability status of connection...
Aug 04 17:49:09: Connection is reachable. Starting connection attempt.
Options error: Unknown key direction '/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/T/connection.z4e19I/secret.key' -- must be '0' or '1'
iMac 21.5 (Late 2012) | 3,1 GHz i7 | 16 GB RAM | OS X 10.10 | Safari 8.0

ingmarstein

Posts: 2
Joined: Tue Jul 29, 2014 11:09 pm

Post by ingmarstein » Tue Aug 05, 2014 2:21 am
b18 seems unable to use my SSL certificate (which is present in the connection details and used to work in earlier versions):
Options error: --pkcs12 fails with 'pkcs.p12': No such file or directory
Options error: Please correct these errors.

astigregg

Posts: 1
Joined: Tue Aug 05, 2014 8:08 am

Post by astigregg » Tue Aug 05, 2014 8:10 am
same issue here for b18. Tried rolling back to b17 just to see what happened, and it's a no-go too (can't find a tmp file).

ingmarstein

Posts: 2
Joined: Tue Jul 29, 2014 11:09 pm

Post by ingmarstein » Tue Aug 05, 2014 2:55 pm
b14 is working for my SSL-based VPN, it's broken since b16 (haven't tried b15).

James

User avatar
Posts: 1924
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Tue Aug 05, 2014 7:35 pm
Build Notice: Viscosity 1.4.11b19 Now Available

If you receive an error message stating that Viscosity's helper tool was unable to be installed/updated under Yosemite please restart your computer or uninstall the old helper tool like so:
Code: Select all
sudo launchctl unload /Library/LaunchDaemons/com.sparklabs.ViscosityHelper.plist
sudo rm /Library/PrivilegedHelperTools/com.sparklabs.ViscosityHelper
sudo rm /Library/LaunchDaemons/com.sparklabs.ViscosityHelper.plist
You can subscribe to this topic by clicking on the "Subscribe topic" link at the bottom of the page to receive email notifications of new beta versions.
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

DJay

Posts: 12
Joined: Tue Jul 16, 2013 6:32 am

Post by DJay » Tue Aug 05, 2014 7:51 pm
With b19 unfortunately still no connection
Code: Select all
Aug 05 11:49:21: Viscosity Mac 1.4.11 (1218)
Aug 05 11:49:21: Viscosity OpenVPN Engine Started
Aug 05 11:49:21: Running on Mac OS X 10.10
Aug 05 11:49:21: ---------
Aug 05 11:49:21: Checking reachability status of connection...
Aug 05 11:49:21: Connection is reachable. Starting connection attempt.
Aug 05 11:49:23: OpenVPN 2.3.4 x86_64-apple-darwin [SSL (OpenSSL)] [LZO] [PKCS11] [MH] [IPv6] built on Jul  2 2014
Aug 05 11:49:23: Cannot open TUN/TAP dev /dev/tun155: No such file or directory (errno=2)
iMac 21.5 (Late 2012) | 3,1 GHz i7 | 16 GB RAM | OS X 10.10 | Safari 8.0

James

User avatar
Posts: 1924
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Tue Aug 05, 2014 8:18 pm
Hi DJay,

That doesn't look directly related to the beta version: I'd recommend you try restarting your computer and ensure no other VPN clients are running at the same time. An adapter number of 155 means you either have a lot of stuck connections or another application is interfering with Viscosity's TUN/TAP drivers.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
166 posts Page 13 of 17